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Important Notice

Your right to copy XPressEntry software and this manual is limited by copyright laws. Making copies,
adaptations, or compilation works (except copies of XPressEntry software for archival purposes as an
essential step in the utilization of the program in conjunction with the equipment), without prior written
authorization of Telaeris, Inc., is prohibited by law and constitutes a punishable violation of the law.

This software and documentation are copyrighted by Telaeris, Inc. The software and documentation are
licensed, not sold, and may be used or copied only in accordance with the Telaeris License Agreement
accompanying the software.

©2024 Telaeris, Inc.
All rights reserved worldwide.
Information in this document is subject to change without notice.

No part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or
by any means, electronic, mechanical, photocopying, recording, scanning, digitizing, or otherwise, without
the prior written consent of Telaeris, Inc.

Trademark Acknowledgements
XPressEntry is a trademark of Telaeris, Inc.

Other company and product names may be trademarks or registered trademarks of their respective
companies and are hereby acknowledged.

Telaeris, Inc.

4101 Randolph Street

San Diego, California 92103
United States of America

(858) 627-9700

www.telaeris.com



http://www.telaeris.com/

Purpose

This document is intended to instruct users on how to synchronize an XPressEntry system with a
Gallagher Command Centre system. XPressEntry has the capability of providing access control
management from a handheld device. For XPressEntry setup information, see the document, “XPressEntry
Installation and Upgrade” found at https://telaeris.com/documentation.

Pre-requisites/Requirements
1. Gallagher Command Centre v8.40+
2. XPressEntry 3.4+
3. Gallagher License Part Numbers for Command Centre REST API
a. C12707 LIC CARDHOLDER CHANGE TRACKING API
C12772 ALARMS AND EVENTS REST API
C12810 LIC STATUS REST API
C12812 LIC OVERRIDES REST API
C12820 INBOUND EVENTS REST API

®oo0o

Setting Up Gallagher Command Centre to Synchronize with

XPressEntry
It is assumed that Gallagher Command Centre is installed.
1. Create XPressEntry Operator or use an existing Operator
a. XPressEntry requires an Operator to be assigned to the REST client. Please create an
XPressEntry operator or use an existing admin level operator.
2. Create REST Client and Enable REST Client
a. Open Gallagher Configuration Client.
b. Navigate to Configure > Services & Workstations
c. Right click the empty space, select New > REST Client

L Services and Workstations — e
Mame Description Type Created Last... Last ..
L FT Bootstrap .. Service 12/15.. 12/15.. Syste..
E FT Controller .. Service 12415, 12A15.. Syste..
Cd FT Waorkstatio .. Work... 12715 12715.. Syste .
Mew.., LJ  Workstation
Delete 3 Command Centre Cloud
Refresh List ||€} REST Client |
opy

d. Set the Name to XPressEntry, or any desired name.


https://telaeris.com/documentation

REST Client 1 - Properties =

General
{} Item Type: REST Client
Event Response
Alarm Instructions Name: | YPressEntry| |
API Key
Connections Description: | |
Icons
Motes Division: £ Root Division ~
Created: 1/18/2024 3:52:05 PM
Last Modified:

Modified by:  £] System Operator

QK Cancel Apply

e. Navigate to API Key and assign the REST Client Operator that XPressEntry will utilize.
REST Client 1 - Properties *

General API Key:
BrEninesiTiEs E83A-22FD-922D-5574-649F-CDEF-FAD1 —8545|

Alarm Instructions
AP Key

Connections Client Certificate Thumbprint:

Icons
MNotes

REST Client Operataor:

ﬁi Admin, Telaens ~

Refresh Operator privileges
REST privileges are cached and will not automatically update when an operator's

privileges change. Be aware that refreshing operator privileges will interrupt any calls
that are in progress,

Enable REST Client

Disabling a REST AFI Client can be a useful short term correction when an integration
is causing a major performance problem with Command Centre

oK Cancel Apply

f. Ensure Enable Rest Client is checked. Click OK.

3. From Gallagher Configuration Client, navigate to File > Server Properties > Web Services.
Check the “Enable Local Network Connections” under the REST API section. If you would like
to set up a Certificate, please do so now. If you are not using a certificate, check the “Enable
REST Clients with no client certificate.”




Telaeris Inc - DEMO - Properties

General Command Centre Mobile App

Licensing Gallagher API Gateway is not enabled.
Ewent Priorities

[ Enable Local Metwork Connections
Alarm Flooding

Server Base Port: | 3201 Device Identification: | TLS Client Certificate ~

Alarm Zone States
Event Defaults
Alarm Instruction Defaults

Status:
Data Port: Stopped

Alarm Transmission

Alarm Motes

Operator Defaults

User Codes and PINs REST APL

Competency Messages Gallagher AFI Gateway is not enabled.
State Names Enable Local Network Connections
Measurement Units Server Base Port:
Advanced Statuss

Web Services Data Port: Stopped

Card Security

Software L\\)
Motifications

Qutgoing Email

Incoming Email Visitor Management Server
Server Base Port:

Mobile,/SMS Notifications 4243
Status:

Import
Visitor Management Port: Running on 4243

Database Maintenance
Challenge

More Challenge
Standards

Mobile Connect Settings
HBUS Terminal Defaults 1
HBUS Terminal Defaults 2
Cameras

Icons

Motes

4. Setup Door in Gallagher

Manage Certificates...

[C]Enable REST Clients with no dient certificate

Manage Certificates. ..

(0]4 Cancel Apply

a. XPressEntry requires Gallagher doors to have an Entry and Exit zone.

b. Open Gallagher Configuration Client.
c. Navigate to Configure > Doors
d.

Add a new door for each XPressEntry handheld. An example name could be “Handheld 17

or “Handheld 1 Door.”

e. Assign the Entry and Exit Zone Access Zones to the door. Click OK.

Handheld 1 - Properties

General

o . .-
Event Response Access Zone _J Inside Facility
Alarm Instructions

Entry is controlled by: Reader(s
Status and Overrides y y ® ®

*

(O Push button(s)

L

Turn off all warning/alarm sounds []

Alarm Transmission Reader(s): - None Selected —-
Connections

Devices -- None Selected --
Entry Zone Disable feedback []

Exit Zone g

Advanced Terminal Display Message:

Challenge Access Granted: |

More Challenge Access Denied: |
Cameras Access Denied (anti-passback): |

Icons

Entry Actions

Exit Actions

Notes Push buttan(s): -- Mone Selected --

-- Mone Selected --

Free
handle

Cancel Apply

Mot fully configured.



5. Setup or verify image Personal Data Field (PDF) is assigned to the Access Group
a. To pull photos into XPressEntry, the cardholders must be a part of an access group with an
image Personal Data Field. The name of the PDF will be added to the XPressEntry setup.

Order of Operations

1. Setup Gallagher Command Centre Data and Settings
2. Enable XPressEntry Synchronization

3. Set up XPressEntry Data

Setup Gallagher Command Centre Data and Settings

XPressEntry uses a module called Data Manager to synchronize all data with Gallagher. From the main
page of XPressEntry, go to XPressEntry > Settings (ALT+S or Tools > Settings).

@ XPressEntry (Administrator) - 3.5.6493 - Telaeris (Logged In User: Administrator, Company)

&
o File Uﬂ Tools @) View f:‘) Logout @Muster

= m] X

Q-

Entry/Ext Mnl Settings Alt+S AddEdt Info Logs
Handheld Status [ & [3 4@ All Zones (Occupancy: 18) Current Occupants ]
Reports Sl Spears, Zachery B Fiowel, Jod Villarreal, Herb
3 s, X I
el 1 Manual Enter/Exit Users 0 Entered. 01/12 02 ntered: 01/12 02 tered: 01/12 0:
=AlZones(!  add Handheld Wizard y . iy
@ Bulkding rvyvey N
2 Door A ) Zone )4 o: Bulding A \_. 2 g #
2 Buiding B (0) S~ Davd, Lecta Atkinson, Garland ' Pineda, Leopoido
1 Door B 2 Entered; 01/12 02 Entered 011202
= Main Lobby (5) B 7 e PR ooty e # 218954
7 Main Door = sl iy as S e e A
1 Door B - 2 G B ; ik
2 Door A HuangMehssa ‘ Robies De.ann ) F'a,éé" Ermrfa(
@ The Yard (0) Mo In Zone: 262 Time £ = 262
2 Bus 123 Badge # 2022 dge &, 64 ﬂ ige ¥ 6582 2

— Klesnhan Donald |

AR Raker Ren Tl Vincent 1via

> E] Activity Occurring in Last Day 0 ]
User User Image ;Il'el:mp ?::r End Zone Door Reader ‘E:::::l od
Spears, Za... 01/12 02:5... Main Lobby Building A  Door A Handheld 2 True |
Howell, Jo... 01/12 02:5... Main Lobby Building A  Door A Handheld 2 True
Villarreal, ... ; 01/12 02:5... Main Lobby Building A  Door A Handheld 2 True
David, Leo... 2 ' 01/12 02:5... Main Lobby Building A  Door A Handheld 2 True
Atkinson, ... ‘ 01/12 02:5.. Main Lobby Building A Door A Handheld 2 True

Activity | Occupancy | Partial | Full ||

Data Manager Tab

Total Occupancy: 18 Inside 2 Zones |

From the Settings page select the Data Manager Tab.
1. Type — This is the integration type. Select Gallagher > Add > Save.
2. Go to Data Manager > Gallagher in the sidebar menu.
3. Setup Data Manager — This sends you to the setup form for Gallagher Command Centre’s data

manager.

0 Unread Messages | Service Running Locally



ntry Settings = [m] X

& x

File Database SQL Import/Export

Type [GALLAGHER -] Add Remove

= General
Add / Edit Display
2:139; Name GALLAGHER Prefix
User Defined Fields
Muster Settings
Question Setup GALLAGHER - Prefix()
Logging
Client Settings
Wiegand Format Data

[ Server
Service Settings
Database

=1 Reader Profiles
Handheld Functionality
Reader Validations
Passwords
Badge Settings
Custom Display
Validation Colors
Doors
Trend Settings

(= Alert Settings
Email Settings
Twilio Alerts

Sanity Check Data

—_— Save Cancel

Sync Timers
XPressEntry uses Timers to pull Gallagher Data into XPressEntry.

al xp try Settings = O X
File Database SQL Import/Export
” | @ Enable Data Manager Type: GALLAGHER Setup Data Manager

= General

[Syne Timers]yne Options

Badges

RFID i

Disable C t
User Defined Fields O 1ea esy:;cu"en Send XPressEntry Activities Now

Muster Settings
Question Setup
Logging Download Activity Frequency Set Clear Download Activity Now
Client Settings -

Wiegand Format Data

O Server Occupancy Sync Frequency Set Clear Occupancy Sync Now
Service Settings .
Database Rartiallsynclpdate Set Clear Partial Sync Now

(= Data Manager Frequency
Software Event Viewer Full Sync Update Frequency Set Clear Full Sync Now

= Reader Profiles
Handheld Functionality
Reader Validations
Passwords
Badge Settings
Custom Display
Validation Colors
Doors
Trend Settings

(= Alert Settings Data Manager Live Log View Unpause Mirror Log To: Browse
Email Settings
Twilio Alerts

Custom Sync Update

Set Clear Custom Sync Now
Frequency

— Save Cancel

1. Download Activity Frequency — Pulls reader scan records into XPressEntry and stores them in
XPressEntry’s activity table. This function also updates the zone occupancy.

2. Occupancy Sync Frequency — Updates the zone occupancy without storing the activity records.

3. Partial Sync Frequency — Pulls all data excluding cardholder data, including readers, areas,



access levels.
4. Full Sync Update Frequency — Updates all tables by pulling all necessary records from Gallagher.
This function may take some time.
a. Itis recommended to run a full sync once per day in the middle of the night when the
system is not busy.
5. Custom Sync Frequency — Updates a set of tables that the user configures.
a. To configure, right click Custom Sync Now and select Edit Custom Sync.

Custom Table Sync - a X
Done L
Table USERS v Partial? D | Table BADGES v Partial? Q

Table GROUPS_USERS v | [ Patial? [x]

Sync Options
=

File Database SQL Import/Export

= General
Add / Edit Display
Badges
RFID
User Defined Fields
Muster Settings
Question Setup
Logging

& Enable Data Manager Type: GALLAGHER

Sync Timers [Sync Options |

. Pull DataManager Occupancy

Default Outside Zone v

[ Pull Data Manager Activities into XPressEntry

Setup Data Manager

Event Processing Retry Count
Default Role

DMPrefix

Client Settings
Wiegand Format Data
=l Server
Service Settings
Database
= Data Manager

Software Event Viewer

. Push XPressEntry Activities to Data Manager

Muster Scanned Users never v

Send Activities Retry Count 3 =

[ Watch Tables via Software Events

- Enable Message Queue

= Reader Profiles
Handheld Functionality
Reader Validations Event Processing Loop Limit 10 2
Passwords
Badge Settings
Custom Display
Validation Colors
Doors
Trend Settings

=l Alert Settings
Email Settings
Twilio Alerts

Message Queue Name \Private$\DataManagerEvent

Clear Data Manager Settings Clear External Data

Data Manager Live Log View Unpause Mirror Log To: Browse

Save Cancel

1. Pull Data Manager Occupancy — Enables use of the Occupancy Sync.

2. Pull Data Manager Activities into XPressEntry — Enables use of the Activity Sync.

3. Push XPressEntry Activities to Data Manager — Enables XPressEntry to push Scan data to
Gallagher Command Centre.

4. Send Activities Retry Count — Number of times XPressEntry will attempt to resend an activity if
it fails.

5. Default Role — The default XPressEntry Role that will be assigned to users if the integration does
not otherwise assign a role. Entrants are recommended but not required.

6. Muster Scanned Users — Enables sync to convert scans from specific readers to be converted into
Muster Scans which mark users as safe. Muster readers must be configured in the reader data.
Please see Mustering Documentation for more details.

7. Setup DataManager Button — Opens Gallagher Command Centre specific settings.



8. Clear DataManager Settings — Resets all settings on the two above tabs, as well as the Gallagher
Command Centre specific settings.

9. Clear External Data — Deletes all data synced from Gallagher Command Centre from the
XPressEntry Database.

Gallagher Data Manager Setup Page
Press the Setup Data Manager button to get the Gallagher Command Centre specific setup screen. In the
new window, you will see the following:

Gallagher Data Manager - O x
Hostname or IP |Iocalhost | Pagination | 100 =
Fad |8304 | Photo Field Name [Photo
APl Key | ,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,, | D Enable Debug Logging

Enable Event on Scan
Enable Location Update on Scan

Test Connect Defaults OK

Status

=

Hostname or IP — IP address of the system where Gallagher server is hosted.

Port — API Port for Gallagher Server.

3. API Key - Found in the Gallagher Configuration Client under Services & Workstations >

XPressEntry > APl Key.

Pagination — Max Pagination size per API query. 100 is recommended.

Photo Field Name — Field name tied to the Gallagher Access Level used to synchronize cardholder

photos.

6. Enable Debug Loggin — Used for additional logging if required

7. Enable Event on Scan — Sends an alarm to Gallagher for each Access Granted and Access Denied
event

8. Enable Location Update on Scan — Moves the cardholder to the area in Gallagher based on the

Access Granted event badge scan

no

o ks

Click Test Connect after entering all the data correctly. This will connect to the Gallagher Command
Centre system using the given user's name and password.

The result will display Connection Success! if connected to Gallagher successfully. If there is any error in
the connection it will show in the same result window.

XPressEntry Data

After setting up the data manager, run the initial Full Sync to pull data from Gallagher Command Centre.
Once the Gallagher Command Centre System is set up and synchronizing, you will see this data
represented in XPressEntry under the Add/Edit Info tab.

Data which is imported from Gallagher Command Centre cannot be changed and is greyed out in
XPressEntry without proper permissions.



Users

Here is a sample of a properly synchronized user:

ﬂ XPressEntry (Administrator) - 3.5.6564 - Telaeris (Logged In User: Administrator, Company)

¢ File t?g Tools @View Q‘ Logout @EHIW/EXH @Musler

Entry/Exit Muster Events Activity History Messages |Add/Edit Info] Logs

- O X

@

Filter. @ = |0

Administrator, Company
Atkinson, Garland
Ayers, Tami

Baker, Rico

Benjamin, Cody

Bright, Til

p
Clay, Billie

David, Leola
Frazier, Emma
Glenn, Malik
Howell, Jodi
Huang, Melissa
Johnson, Bill
Kemp, Alfie
Kemp, Genaro
Kleinhen, Donald L.
Luna, Rosanne
Lynch, Esther
Mcgee, Adan
Merritt, Theo
Mora, Juliana
Pineda, Leopoldo
Rables, Deann
Rojas, Everly
Rosales, Mary
Sanders, Erin
Sawyer, Quinn
Smith, Jane
Smith, John
Spears, Zachery
Stanley, Kade
Stevenson, Layla
Swanson, Robbie
Thornton, Safa
Villa, Dominik

‘ Time to Read 42 Records: 0.88 seconds ‘

. UserSI L] Companies % Groups £t Zones [ Doors [] Readers & Roles @ Timezones L: Muster Sites

Permiss\ons Contact Info  UDFs/Misc

First Name Last Name mi Photo FP
Silas Campos
Company ~
Emp ID (] visitor

Zone  Outside v [J Host
Zone Entry: 03/08 08:25:57 AM
Last Reader.

Role  Entrant M Change | Crop

Start Date
End Dato

Delete

Badges N ~ . .
(0) @ Add Badge @ Delete Badge © View History = Print Badge
Badge Activated Date Expired Date Invalid Badge Type
> 890 0 M~
ew elete ave ance
Add N Delet S C I

Activity | Occupancy| Partial | Full[| |

0 Unread Messages

Service Running Locally

All External Records (From Gallagher Command Centre) will display in red as an External Record at the
top of the form. This label will not display for any records that were created from within XPressEntry.

XPressEntry will pull the user’s image and badge number from Gallagher Command Centre. The badge
number can be seen at the bottom of the screen.

User Permissions
Users in XPressEntry have the same permissions to each reader as they do in Gallagher Command Centre.

This is regardless of whether the user is assigned an Access Code, Reader Group, or direct access to a

Reader.

u XPressEntry (Administrator) - 3.5.6564 - Telaeris (Logged

Filter- @ = O
Administrator, Company
Atkinson, Garland
Ayers, Tami

Baker, Rico
Benjamin, Cody
Bnight, Til

Clay, Bilie

David, Leola
Frazier, Emma
Glenn, Malik
Howell, Jodi
Huang, Melissa
Johnson, Bill
Kemp, Alfie
Kemp, Genaro
Kieinhen, Donald L.
Luna, Rosanne
Lynch, Esther
Mcgee, Adan
Meritt, Theo
Mora, Julana
Pineda, Leopoido
Robles, Deann
Rojas, Everly
Rosales, Mary
Sanders, Enin
Sawyer, Quinn
Smith, Jane
Smith, John
Spears, Zachery
Stanley, Kade
Stevenson, Layla
Swanson, Robbie
Thomton, Safa
Villa, Dominik

| Time to Read 42 Records: 0.88 semnds‘

Activity | Occupancy | Partial | Full|| |

In User: Administrator, Company) =

ﬁg Tools @Vim q& Logout @Enhy,’&:ir @Muster

EnirylExil Muster Events Actiity History Messages [AGGEGR Info] Logs

11 Companies @ Groups i Zones [ Doors [] Readers & Roles @ Timezones - Muster Sites
User |Pemissions | Cantact Infe UDFs/Misc

Access Groups o Add User to Group

All Access.
Bus Access

Group A
Allow User to Zone

Direct Zone Permissions o Allow User to Timezane

Zone Name

Allowed Times o

Timezone
Name

Start EndTime Mon

Add New Delete Save Cancel

0 Unread Messages | Service Running Locally

X

o
@




Doors
al

€ File [Kﬂ Tools @) View :‘ Logout @Entry/Exit @Muster @Help

Entry/Exit Muster Events Activity History Messages |Add/Edit Info | Logs

Filter @ | = @ % Users ol Companies & Groups % Zones D Readers & Roles @ Timezones L- Muster Sites

Bus 123

Door B Door A
Main Door

Door Name

Start Zone
Main Lobby v

End Zone
Building A v

Door RFID Tag#

External Entry Reader

External Exit Reader

Add New Delete

‘ Time to Read 4 Records: 0.01 seconds ‘

Activity | Occupancy | Partial | Full || | 0 Unread Messages Service Running Locally

Entry/Exit permissions in XPressEntry are set by doors Doors contain two readers — an exit
and an entry reader.

Door access is determined by the user’s access to the door’s reader. For entry, permission is
based on the user’s access to the door’s external entry reader. For exit, permission is based
on the user’s access to the door’s external exit reader. Doors should be set by the user for
each Handheld Reader in XPressEntry.

1. For each door, set the start zone to Outside and the end zone to Building. This helps
to determine directionality.
2. For proper occupancy tracking, set the start and end zone to zones created in the
Zones tab.
a. Start zone — The area the user will enter from.
i. External Entry Reader will be assigned to the Gallagher Reader
created for Entry.
b. End zone — The area end user will end up.
i. External Exit Reader will be assigned to the Gallagher Reader
created for Exit if there is one.
Activities
XPressEntry will synchronize activities to Gallagher if that option has been set by the
Data Manager.

Entry/Exit activities will be sent to Gallagher and display the results in the
Transaction logs as an alarm. There is also the option to update the cardholder
location within Gallagher based on the handheld badge scan.



